View On GitHub


Dictionaries of external rings

Version 2018.02.04

Download .tar.gz Download .zip

GAP Package RingsForHomalg

The RingsForHomalg package provides small dictionaries for homalg to speak (as much as needed of) the languages of Singular, Macaulay2, MAGMA, Sage, and Maple

The current version of this package is version 2018.02.04. For more information, please refer to the package manual. There is also a README file.


This package requires GAP version >=4.7

The following other GAP packages are needed:


Mohamed Barakat, Simon Goertzen, Markus Kirschmer, Markus Lange-Hegermann, Oleksandr Motsak, Daniel Robertz, Hans Schönemann, Andreas Steenpaß, Vinay Wagh


For bug reports, feature requests and suggestions, please use the issue tracker.