View On GitHub

PolymakeInterface

A package to provide algorithms for fans and cones of polymake to other packages

Version 2015.11.06

Download .tar.gz Download .zip

GAP Package PolymakeInterface

PolymakeInterface is a GAP-Package that provides a link to the callable library of the CAS polymake. It is not supposed to do any work by itself, but to provide the methods in polymake to GAP. All the functions in this package are supposed to be capsuled by functions in the Convex package, which provides needed structures and datatypes. Also the functions the have nicer names. This fact also causes that there are no doumentations for functions in this package. To get an overview about the supported functions, one might look at the polymake_main.cpp file or simply message the author. Working with this package alone without Convex is not recommended.

The current version of this package is version 2015.11.06. For more information, please refer to the package manual. There is also a README file.

Dependencies

This package requires GAP version >=4.7

The following other GAP packages are needed:

Authors

Thomas Baechler, Sebastian Gutsche

Feedback

For bug reports, feature requests and suggestions, please use the issue tracker.